6 Comments on “Time to get excited again…

  1. No it’s me running Linux and not noticeing the ‘Additional plugins are required…’ in firefox, when I click on install I get unknown plugin video/x-ms-wmv (or whatever) I guess the wmv plugin is a windows builtin and just doesn’t exist for Linux

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.